[Nix-dev] Re: mostly minimal Nixos built using gold ld where possible
ludo at gnu.org
Fri Mar 19 19:16:59 CET 2010
Rohan Hart <rohan.hart17 at gmail.com>
> 2010/3/18 Ludovic Courtès <ludo at gnu.org>:
>> Rohan Hart <rohan.hart17 at gmail.com>
>>> Many of the package level changes are due to Gold being more strict in
>>> ensuring that all symbols can be found at link time. In most cases
>>> I've simply added an LDFLAGS = ... entry in the derivation.
>> Some of them are a bit surprising. For instance, AFAICS, libgcrypt does
>> pass ‘-lgpg-error’ when linking (see
>> <http://hydra.nixos.org/build/325591/log/raw>). Do you remember the
>> details? Could it have something to do with the magic in the GCC/ld
> In this particular case the error is when building the tests:
> Given that someone's built all of Debian with Gold I'm surprised that
> the upstream packages haven't started to configure themselves
> correctly. More bug reports to file.
Yeah. It may be that problems haven’t been reported upstream.
>>> If a hydra branch of nixpkgs was created I'd be happy to (slowly) fix
>>> packages till there's a stable build. In the mean time I'd like to be
>>> able to use Nixos without multi-day compile delays ;-)
>> I second your request and invite you to create a branch for this!
> I assume that would require a subversion branch? And a separate channel?
A separate branch and Hydra jobset.
Actually, things could be committed to ‘trunk’ as long as (1) users can
choose between GNU ld and GNU Gold, and (2) the default remains GNU ld.
Before committing to ‘trunk’, you’d have to make sure that it won’t
cause too many rebuilds, and in particular that it doesn’t affect
‘stdenv’; otherwise that could go to ‘stdenv-updates’.
What do you think?
>> One nitpick:
>> Instead of ‘binutilsOld’ and ‘gccOld’, which aren’t very descriptive,
>> how about ‘binutilsGold’ and ‘gccGold’?
> Since I made Gold the default I wanted to call that derivation simply
> binutils as that lets inherit work as normal. A better name for the
> non-Gold binutils is needed. binutilsNonGold isn't much better. Any
Well, ‘binutilsGold’ has the advantage of being shorter and as
descriptive as ‘binutilsNonGold’. ;-)
More information about the nix-dev